Si estas leyendo este artículo es probable que te encuentres aquí por que intentaste instalar algún scrit basado en Python y te marca dependencias no satisfechas.
Un ejemplo muy común es instalar HPLIP, que para instalarse necesita solucionar dependencias de versiones anteriores de Python.

Desde Ubuntu 20.04 se volvió bastante difícil solucionar estas dependencias debido a la antigua biblioteca pyqt5 utilizada.
Así que para poder resolver las dependencias de pyqt5 en la versión de Python 3 es necesario ejecutar el siguiente comando en la terminal.

sudo apt install python-dev-is-python3/focal

De esta forma la llamada a las librerías se resuelve. Eso si, hay que instalar las nuevas librerías para poder hacer la referencia.